summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD339
1 files changed, 339 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c469ff46f40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,339 @@
+# Maintainer : Maxim Fomin <(maxim at fomin dot one)>
+# Maintainer : Christian Hesse <mail@eworm.de>
+# Maintainer : Ronald van Haren <ronald.archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+
+## "1" to enable IA32-EFI build in Arch x86_64, "0" to disable
+_IA32_EFI_IN_ARCH_X64="1"
+
+## "1" to enable EMU build, "0" to disable
+_GRUB_EMU_BUILD="0"
+
+_GRUB_EXTRAS_COMMIT="8a245d5c1800627af4cefa99162a89c7a46d8842"
+_GNULIB_COMMIT="be584c56eb1311606e5ea1a36363b97bddb6eed3"
+_UNIFONT_VER="13.0.05"
+
+[[ "${CARCH}" == "x86_64" ]] && _EFI_ARCH="x86_64"
+[[ "${CARCH}" == "i686" ]] && _EFI_ARCH="i386"
+
+[[ "${CARCH}" == "x86_64" ]] && _EMU_ARCH="x86_64"
+[[ "${CARCH}" == "i686" ]] && _EMU_ARCH="i386"
+
+pkgname='grub-luks-keyfile-git'
+pkgdesc='GNU GRand Unified Bootloader (2)'
+epoch=2
+pkgver=2.05
+pkgrel=1
+url='https://www.gnu.org/software/grub/'
+arch=('x86_64')
+license=('GPL3')
+backup=('etc/grub.d/40_custom')
+options=('!makeflags')
+
+conflicts=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub-legacy')
+replaces=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
+provides=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
+
+makedepends=('git' 'rsync' 'xz' 'freetype2' 'ttf-dejavu' 'python' 'autogen'
+ 'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse2')
+depends=('sh' 'xz' 'gettext' 'device-mapper')
+optdepends=('freetype2: For grub-mkfont usage'
+ 'fuse2: For grub-mount usage'
+ 'dosfstools: For grub-mkrescue FAT FS and EFI support'
+ 'efibootmgr: For grub-install EFI support'
+ 'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
+ 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
+ 'mtools: For grub-mkrescue FAT FS support')
+
+if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
+ makedepends+=('libusbx' 'sdl')
+ optdepends+=('libusbx: For grub-emu USB support'
+ 'sdl: For grub-emu SDL support')
+fi
+
+validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
+ 'BE5C23209ACDDACEB20DB0A28C8189F1988C2166' # Daniel Kiper <dkiper@net-space.pl>
+ '95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
+
+source=("git+https://git.savannah.gnu.org/git/grub.git"
+ "git+https://git.savannah.gnu.org/git/grub-extras.git#commit=${_GRUB_EXTRAS_COMMIT}"
+ "git+https://git.savannah.gnu.org/git/gnulib.git#commit=${_GNULIB_COMMIT}"
+ "https://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz"{,.sig}
+ '0003-10_linux-detect-archlinux-initramfs.patch'
+ '0004-add-GRUB_COLOR_variables.patch'
+ '0001-Cryptomount-support-LUKS-detached-header.patch'
+ '0002-Cryptomount-support-key-files.patch'
+ '0003-Cryptomount-luks-allow-multiple-passphrase-attempts.patch'
+ '0004-Cryptomount-support-plain-dm-crypt.patch'
+ '0005-Cryptomount-support-for-hyphens-in-UUID.patch'
+ '0006-Cryptomount-support-for-using-whole-device-as-keyfile.patch')
+
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'c4e61e9336d8d024479ea72616722c6c47c93f76dc173e8ad3edf9f9e07c3115'
+ 'SKIP'
+ '171415ab075d1ac806f36c454feeb060f870416f24279b70104bba94bd6076d4'
+ 'a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29'
+ 'b9d737d1b403b540a00a8e9c25240a06bb371da7588d3e665af8543397724698'
+ '5d7060fbe9738764d2f8ebc96b43cc0bb8939c2e4e4e78b7a82a1a149ea6e837'
+ '3e373bcb7847326ae14365e7443f900559f35f4f9ba2e5e69d034f4423fc45bb'
+ '9ff4aba657d3826a510c57ce44d7582c4e4c72eb32a59ffd2b09e923202750ed'
+ '6f58b01eb9adcc6864e09a4ecaa728f19ee2c9a7ecf4cf20fd17fc5ec327f19c'
+ '4739a472c609df2528ac30e502a9f1b77fd1517af551c6bcbd35ba57b81da827')
+
+_backports=(
+ # grub-mkconfig: Use portable "command -v" to detect installed programs
+ '28a7e597de0d5584f65e36f9588ff9041936e617'
+)
+
+_configure_options=(
+ FREETYPE="pkg-config freetype2"
+ BUILD_FREETYPE="pkg-config freetype2"
+ --enable-mm-debug
+ --enable-nls
+ --enable-device-mapper
+ --enable-cache-stats
+ --enable-grub-mkfont
+ --enable-grub-mount
+ --prefix="/usr"
+ --bindir="/usr/bin"
+ --sbindir="/usr/bin"
+ --mandir="/usr/share/man"
+ --infodir="/usr/share/info"
+ --datarootdir="/usr/share"
+ --sysconfdir="/etc"
+ --program-prefix=""
+ --with-bootdir="/boot"
+ --with-grubdir="grub"
+ --disable-silent-rules
+ --disable-werror
+)
+
+prepare() {
+ cd "${srcdir}/grub/"
+
+ echo "Apply backports..."
+ local _c
+ for _c in "${_backports[@]}"; do
+ git log --oneline -1 "${_c}"
+ git cherry-pick -n "${_c}"
+ done
+
+ echo "Patch to detect of Arch Linux initramfs images by grub-mkconfig..."
+ patch -Np1 -i "${srcdir}/0003-10_linux-detect-archlinux-initramfs.patch"
+
+ echo "Patch to enable GRUB_COLOR_* variables in grub-mkconfig..."
+ ## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
+ patch -Np1 -i "${srcdir}/0004-add-GRUB_COLOR_variables.patch"
+
+ echo "Patch to enable LUKS detached header support..."
+ patch -Np1 -i "${srcdir}/0001-Cryptomount-support-LUKS-detached-header.patch"
+
+ echo "Patch to enable LUKS key files support ..."
+ patch -Np1 -i "${srcdir}/0002-Cryptomount-support-key-files.patch"
+
+ echo "Patch to enable multiple passphrase attempts support..."
+ patch -Np1 -i "${srcdir}/0003-Cryptomount-luks-allow-multiple-passphrase-attempts.patch"
+
+ echo "Patch to enable plain dm-crypt mode support..."
+ patch -Np1 -i "${srcdir}/0004-Cryptomount-support-plain-dm-crypt.patch"
+
+ echo "Patch to enable hyphens in UUID support..."
+ patch -Np1 -i "${srcdir}/0005-Cryptomount-support-for-hyphens-in-UUID.patch"
+
+ echo "Patch to enable whole device as keyfile support ..."
+ patch -Np1 -i "${srcdir}/0006-Cryptomount-support-for-using-whole-device-as-keyfile.patch"
+
+ echo "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme..."
+ sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
+
+ echo "Fix mkinitcpio 'rw' FS#36275..."
+ sed 's| ro | rw |g' -i "util/grub.d/10_linux.in"
+
+ echo "Fix OS naming FS#33393..."
+ sed 's|GNU/Linux|Linux|' -i "util/grub.d/10_linux.in"
+
+ echo "Pull in latest language files..."
+ ./linguas.sh
+
+ echo "Avoid problem with unifont during compile of grub..."
+ # http://savannah.gnu.org/bugs/?40330 and https://bugs.archlinux.org/task/37847
+ gzip -cd "${srcdir}/unifont-${_UNIFONT_VER}.bdf.gz" > "unifont.bdf"
+
+ echo "Run bootstrap..."
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
+
+ echo "Make translations reproducible..."
+ sed -i '1i /^PO-Revision-Date:/ d' po/*.sed
+}
+
+_build_grub-common_and_bios() {
+ echo "Set ARCH dependent variables for bios build..."
+ if [[ "${CARCH}" == 'x86_64' ]]; then
+ _EFIEMU="--enable-efiemu"
+ else
+ _EFIEMU="--disable-efiemu"
+ fi
+
+ echo "Copy the source for building the bios part..."
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-bios/"
+ cd "${srcdir}/grub-bios/"
+
+ echo "Add the grub-extra sources for bios build..."
+ install -d "${srcdir}/grub-bios/grub-extras"
+ cp -r "${srcdir}/grub-extras/915resolution" \
+ "${srcdir}/grub-bios/grub-extras/915resolution"
+ export GRUB_CONTRIB="${srcdir}/grub-bios/grub-extras/"
+
+ echo "Unset all compiler FLAGS for bios build..."
+ unset CFLAGS
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset MAKEFLAGS
+
+ echo "Run ./configure for bios build..."
+ ./configure \
+ --with-platform="pc" \
+ --target="i386" \
+ "${_EFIEMU}" \
+ --enable-boot-time \
+ "${_configure_options[@]}"
+
+ if [ ! -z "${SOURCE_DATE_EPOCH}" ]; then
+ echo "Make info pages reproducible..."
+ touch -d "@${SOURCE_DATE_EPOCH}" $(find -name '*.texi')
+ fi
+
+ echo "Run make for bios build..."
+ make
+}
+
+_build_grub-efi() {
+ echo "Copy the source for building the ${_EFI_ARCH} efi part..."
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-efi-${_EFI_ARCH}/"
+ cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
+
+ echo "Unset all compiler FLAGS for ${_EFI_ARCH} efi build..."
+ unset CFLAGS
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset MAKEFLAGS
+
+ echo "Run ./configure for ${_EFI_ARCH} efi build..."
+ ./configure \
+ --with-platform="efi" \
+ --target="${_EFI_ARCH}" \
+ --disable-efiemu \
+ --enable-boot-time \
+ "${_configure_options[@]}"
+
+ echo "Run make for ${_EFI_ARCH} efi build..."
+ make
+}
+
+_build_grub-emu() {
+ echo "Copy the source for building the emu part..."
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-emu/"
+ cd "${srcdir}/grub-emu/"
+
+ echo "Unset all compiler FLAGS for emu build..."
+ unset CFLAGS
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset MAKEFLAGS
+
+ echo "Run ./configure for emu build..."
+ ./configure \
+ --with-platform="emu" \
+ --target="${_EMU_ARCH}" \
+ --enable-grub-emu-usb=no \
+ --enable-grub-emu-sdl=no \
+ --disable-grub-emu-pci \
+ "${_configure_options[@]}"
+
+ echo "Run make for emu build..."
+ make
+}
+
+build() {
+ cd "${srcdir}/grub/"
+
+ echo "Build grub bios stuff..."
+ _build_grub-common_and_bios
+
+ echo "Build grub ${_EFI_ARCH} efi stuff..."
+ _build_grub-efi
+
+ if [[ "${CARCH}" == "x86_64" ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" == "1" ]]; then
+ echo "Build grub i386 efi stuff..."
+ _EFI_ARCH="i386" _build_grub-efi
+ fi
+
+ if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
+ echo "Build grub emu stuff..."
+ _build_grub-emu
+ fi
+}
+
+_package_grub-common_and_bios() {
+ cd "${srcdir}/grub-bios/"
+
+ echo "Run make install for bios build..."
+ make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
+
+ echo "Remove gdb debugging related files for bios build..."
+ rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.module || true
+ rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.image || true
+ rm -f "${pkgdir}/usr/lib/grub/i386-pc"/{kernel.exec,gdb_grub,gmodule.pl} || true
+}
+
+_package_grub-efi() {
+ cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
+
+ echo "Run make install for ${_EFI_ARCH} efi build..."
+ make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
+
+ echo "Remove gdb debugging related files for ${_EFI_ARCH} efi build..."
+ rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.module || true
+ rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.image || true
+ rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/{kernel.exec,gdb_grub,gmodule.pl} || true
+}
+
+_package_grub-emu() {
+ cd "${srcdir}/grub-emu/"
+
+ echo "Run make install for emu build..."
+ make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
+
+ echo "Remove gdb debugging related files for emu build..."
+ rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.module || true
+ rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.image || true
+ rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/{kernel.exec,gdb_grub,gmodule.pl} || true
+}
+
+package() {
+ cd "${srcdir}/grub/"
+
+ echo "Package grub ${_EFI_ARCH} efi stuff..."
+ _package_grub-efi
+
+ if [[ "${CARCH}" == "x86_64" ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" == "1" ]]; then
+ echo "Package grub i386 efi stuff..."
+ _EFI_ARCH="i386" _package_grub-efi
+ fi
+
+ if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
+ echo "Package grub emu stuff..."
+ _package_grub-emu
+ fi
+
+ echo "Package grub bios stuff..."
+ _package_grub-common_and_bios
+}