summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD30
1 files changed, 10 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ae502955f58..ba27f1399b8d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,29 @@
#Maintainer: Lubosz <lubosz@gmail.com>
#Contributor: helq <linuxero789@gmail.com>
+#Contributor: junglerobba <tobias.langendorf@gmail.com>
-pkgname=gsettings-desktop-schemas-git
+pkgname=gsettings-desktop-schemas-dev
_realpkgname=gsettings-desktop-schemas
-pkgver=3.8.0.5.gca797db
+pkgver=3.31.0.1
pkgrel=1
pkgdesc="Shared GSettings schemas for the desktop"
arch=(i686 x86_64)
-url="http://live.gnome.org/"
+url="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
license=('GPL')
-depends=('glib2-git' 'intltool')
-makedepends=('git')
-options=(makeflags !emptydirs)
+depends=(glib2 intltool)
+makedepends=(git meson gobject-introspection)
provides=("${_realpkgname}")
conflicts=("${_realpkgname}")
-source="git://git.gnome.org/gsettings-desktop-schemas"
+source=("git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#tag=${pkgver}")
sha256sums=('SKIP')
-_gitname="gsettings-desktop-schemas"
-install=gsettings-desktop-schemas.install
-
-pkgver() {
- cd $_gitname
- git describe --always | sed 's|-|.|g'
-}
-
build() {
- cd $_gitname
- ./autogen.sh --prefix=/usr || return 1
- make || return 1
+ arch-meson gsettings-desktop-schemas build
+ ninja -C build
}
package() {
- cd $_gitname
- make DESTDIR=$pkgdir install || return 1
+ DESTDIR="$pkgdir" meson install -C build
}