summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 20 insertions, 46 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c77a76e45e8..74694c8df3d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gst-plugins-ugly-git
-_srcname=gst-plugins-ugly
-pkgver=1.15.0.1.r5505.g59d43105
+pkgver=1.16.0.r16.g3cd445a4
pkgrel=1
pkgdesc='GStreamer Multimedia Framework Ugly Plugins (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://gstreamer.freedesktop.org/'
license=('LGPL')
depends=(
@@ -16,67 +15,42 @@ depends=(
# AUR:
'gstreamer-git' 'gst-plugins-base-git'
)
-makedepends=('git' 'python' 'gtk-doc' 'autoconf-archive')
+makedepends=('git' 'meson' 'python' 'gtk-doc')
provides=("gst-plugins-ugly=${pkgver%%.r*}")
conflicts=('gst-plugins-ugly')
-source=('git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly.git'
- 'gst-common'::'git+https://anongit.freedesktop.org/git/gstreamer/common.git')
+source=('git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly.git'
+ 'gst-common'::'git+https://gitlab.freedesktop.org/gstreamer/common.git')
sha256sums=('SKIP'
'SKIP')
prepare() {
- cd "$_srcname"
-
+ cd gst-plugins-ugly
+
git submodule init
git config --local submodule.common.url "${srcdir}/gst-common"
git submodule update
-
- NOCONFIGURE='1' ./autogen.sh
}
pkgver() {
- cd "$_srcname"
-
- local _version
- local _revision
- local _shorthash
-
- _version="$(grep 'AC_INIT' configure.ac | sed 's/,\[http.*//;s/AC_INIT.*\],//;s/.*\[\([^]]*\)\].*/\1/g')"
- _revision="$(git rev-list --count HEAD)"
- _shorthash="$(git rev-parse --short HEAD)"
-
- printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
+ cd gst-plugins-ugly
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$_srcname"
-
- ./configure \
- --prefix='/usr' \
- --sysconfdir='/etc' \
- --localstatedir='/var' \
- --libexecdir='/usr/lib' \
- --enable-shared \
- --disable-static \
- --enable-experimental \
- --enable-gtk-doc \
- --with-package-name='GStreamer Ugly Plugins (Arch Linux)' \
- --with-package-origin='http://www.archlinux.org/'
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ arch-meson gst-plugins-ugly build \
+ -D gobject-cast-checks='disabled' \
+ -D glib-asserts='disabled' \
+ -D glib-checks='disabled' \
+ -D doc='disabled' \
+ -D package-name='GStreamer Ugly Plugins (Arch Linux)' \
+ -D package-origin='https://www.archlinux.org/'
+ ninja -C build
}
check() {
- cd "$_srcname"
-
- make check
+ meson test -C build --print-errorlogs
}
package() {
- cd "$_srcname"
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}