summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5c8928a12ff..690b2e00a9b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,21 +9,26 @@
pkgname=gstm
pkgver=1.3.7
-pkgrel=2
+pkgrel=3
pkgdesc="Gnome SSH Tunnel Manager - Gtk3 Edition"
arch=('i686' 'x86_64')
url="https://github.com/dallenwilson/gstm"
license=('GPL')
-depends=('openssh' 'libxml2' 'glib2' 'gdk-pixbuf2' 'gtk3')
-makedepends=('intltool')
+depends=('openssh' 'libxml2' 'glib2' 'gdk-pixbuf2' 'gtk3' 'libappindicator-gtk3')
+makedepends=('intltool' 'autoconf' 'automake' 'gcc')
conflicts=('gstm-git' 'gstm-gtk2')
provides=('gstm')
source=(https://github.com/dallenwilson/gstm/releases/download/${pkgver}/gstm-${pkgver}.tar.gz)
sha256sums=('77eb25e3aedc6ecf6f00812569200424d6d327a296289f4141b6881d9be3e655')
+prepare() {
+ cd ${srcdir}/gstm-${pkgver}
+ #./autogen.sh
+ autoconf -I m4
+}
+
build() {
cd ${srcdir}/gstm-${pkgver}
- ./autogen.sh
./configure --prefix=/usr
make || return 1
}