summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 283b026924e3..e7b2f25821b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer Yurii Kolesnykov <yurikoles@gmail.com>
+# Maintainer gCurse <gcurse at web dot de>
# Credit: Jan de Groot <jgc@archlinux.org>
pkgbase=gstreamer0.10-bad
_pkgname=gst-plugins-bad
pkgname=('gstreamer0.10-bad' 'gstreamer0.10-bad-plugins')
pkgver=0.10.23
-pkgrel=37
+pkgrel=38
arch=('i686' 'x86_64' 'armv7h')
license=('LGPL' 'GPL')
-makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36-3' 'xvidcore' 'libdca'
+makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36-11' 'xvidcore' 'libdca'
'bzip2' 'libdc1394' 'neon' 'faac' 'libmusicbrainz5' 'faad2'
'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav'
'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau'
'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump'
'libsndfile' 'librsvg' 'wildmidi' 'opus' 'git' 'spandsp' 'celt'
'openssl-1.0')
-url="https://github.com/triceratops1/gstreamer0"
+url="http://gstreamer.freedesktop.org/"
options=(!emptydirs)
-source=("git+https://gitlab.com/gstreamer-sdk/$_pkgname.git#commit=57569a4854a0f2d14ef19a8264a4ae9a7a1d1125"
+source=("https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-0.10.23.tar.xz"
fix-libmodplug-include.patch
drop-vpx-compat-defs.patch
disable-assrender-test.patch
@@ -25,7 +25,7 @@ source=("git+https://gitlab.com/gstreamer-sdk/$_pkgname.git#commit=57569a4854a0f
faad2-version-check.patch
wildmidi-0.4.patch
flite_cmu_us_kal.patch)
-sha256sums=('SKIP'
+sha256sums=('03cf0786391c64625569072e904082a08861f05a63d64b2f8e8dad3f26d81bf9'
'd89d8f4307c7d5a143b9240467d260a1cb6bb1ab2e7ca57841ce0901f41c9cb7'
'eb97037b7b581d1ab994eadd144044c083975e5670a73ec827de126bf888f4b9'
'e66642affa6c0e69837d37615010e67e59ef3d672663303d46c1e2591e2ddfc6'
@@ -35,7 +35,7 @@ sha256sums=('SKIP'
'e3b6a6a8bd0480ab812116cb472b92ad5770fdb8afdbdc2a5b557fdd0294ad36')
prepare() {
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
patch -Np1 -i ../fix-libmodplug-include.patch
patch -Np1 -i ../drop-vpx-compat-defs.patch
@@ -47,7 +47,7 @@ prepare() {
}
build() {
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
NOCONFIGURE=1 ./autogen.sh
CPPFLAGS=-I/usr/include/openssl-1.0 LDFLAGS=-L/usr/lib/openssl-1.0 \
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
@@ -62,9 +62,9 @@ build() {
package_gstreamer0.10-bad() {
pkgdesc="GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad)"
- depends=('gstreamer0.10-base>=0.10.34')
+ depends=('gstreamer0.10-base>=0.10.36-11')
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}
@@ -75,10 +75,10 @@ package_gstreamer0.10-bad-plugins() {
'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa'
'libvdpau' 'soundtouch' 'libass' 'schroedinger' 'libvpx' 'gsm' 'rtmpdump'
'libgme' 'libsndfile' 'librsvg' 'wildmidi' 'opus' 'celt' 'spandsp'
- 'openssl-1.0')
+ 'openssl-1.0' 'dconf')
groups=('gstreamer0.10-plugins')
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
make -C gst-libs DESTDIR="${pkgdir}" install
make -C ext DESTDIR="${pkgdir}" install
make -C sys DESTDIR="${pkgdir}" install