summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b1cf511fc15..ff29192792c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Alban Fichet <alban.fichet@inria.fr>
pkgname=gthumb-openexr-extension
-pkgver=2.0
-pkgrel=7
+pkgver=3.10
+pkgrel=8
pkgdesc="Extension for gThumb to support OpenEXR"
arch=('any')
url="https://github.com/yama-chan/gthumb-openexr-extension"
license=('GPL')
depends=('git' 'gthumb>=3.10' 'glib2' 'gtk3' 'gconf' 'openexr')
-makedepends=('git' 'gnome-common')
+makedepends=('git' 'gnome-common' 'cmake')
checkdepends=()
provides=($pkgname=$pkgver)
-source=("$pkgname::git+https://github.com/yama-chan/$pkgname.git")
+source=("$pkgname::git+https://github.com/yama-chan/$pkgname.git#branch=cmake")
md5sums=('SKIP')
prepare() {
@@ -19,7 +19,8 @@ prepare() {
build() {
cd "$pkgname"
- ./autogen.sh --prefix /usr CFLAGS="-I/usr/include/gthumb"
+ cmake . -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
+ #./autogen.sh --prefix /usr CFLAGS="-I/usr/include/gthumb"
make
}