summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 28 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07479dfa832c..f273d2e24e07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,52 @@
-# Maintainer: Joaquin Garmendia <joaquingc123 at gmail dot com>
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributor: Joaquin Garmendia <joaquingc123 at gmail dot com>
# Contributor: Orestis Floros <orestisf1993@gmail.com>
-# All my PKGBUILDs can be found in https://www.github.com/joaquingx/PKGBUILDs
-
pkgname=gtk-arc-flatabulous-theme-git
_pkgname=arc-flatabulous-theme
-pkgver=20180201.r0.g0492475
+pkgver=r905.6658eac
pkgrel=1
pkgdesc="Arc theme with Flatabulous window controls."
arch=('any')
url="https://github.com/andreisergiu98/${_pkgname}"
license=('GPL3')
-makedepends=('git' 'gtk3' 'sassc')
+depends=()
+makedepends=('git' 'autoconf' 'automake' 'sassc' 'optipng' 'inkscape')
optdepends=('gtk-engine-murrine: for gtk2 themes'
- 'gnome-themes-standard: for gtk2 themes'
- 'arc-icon-theme: recommended icon theme'
- 'gtk3: for gtk3 themes'
- )
-source=("git+${url}")
-sha256sums=('SKIP')
+ 'gnome-themes-extra: for gtk2 themes'
+ 'gtk3: for gtk3 themes'
+ 'gnome-shell: for detecting GNOME Shell version'
+)
provides=('gtk-arc-flatabulous-theme')
conflicts=('gtk-arc-flatabulous-theme')
+source=("git+${url}")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${_pkgname}"
- autoreconf -fi
+_autogen_options=()
+
+check_optdepends() {
+ # Check if gnome-shell is installed
+ if (pacman -Qq gnome-shell > /dev/null) ; then
+ msg "Enabling GNOME Shell support"
+ else
+ msg "Disabling GNOME Shell support"
+ _autogen_options=(${_autogen_options[@]} --disable-gnome-shell)
+ fi
}
build() {
+
+ # Check optional dependencies
+ check_optdepends
+
cd "${srcdir}/${_pkgname}"
- ./configure --prefix=/usr
+ ./autogen.sh ${_autogen_options[@]} --prefix=/usr
+ make
}
package() {