summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfaa7d619ae4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=gtk-sharp-3-git
+pkgver=2.12
+pkgrel=1
+pkgdesc="C# bindings for GTK+ 2, built from sources."
+arch=('any')
+url="https://mono-project.com/GtkSharp"
+license=('GPL')
+depends=('mono' 'gtk2' 'libglade')
+provides=('gtk-sharp-2')
+conflicts=('gtk-sharp-2')
+source=("git://github.com/mono/gtk-sharp.git#branch=gtk-sharp-2-12-branch")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/gtk-sharp"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/gtk-sharp"
+ make DESTDIR="$pkgdir" install
+}