summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD102
1 files changed, 66 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5fc59e78cad..a0a7a71299dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,86 @@
# Maintainer: dudemanguy <random342@airmail.cc>
# Contributor: Vaporeon <vaporeon@tfwno.gf>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gtk2-patched-filechooser-icon-view
-pkgver=2.24.32
-pkgrel=2
+pkgver=2.24.33
+pkgrel=3
+pkgdesc="GTK2 patched with ahodesuka's filechooser-icon-view patch"
+url="https://github.com/Dudemanguy/gtk/tree/gtk2-filechooser-icon-view"
arch=(x86_64)
-pkgdesc="https://github.com/Dudemanguy/gtk/tree/gtk2-filechooser-icon-view"
-url="https://gist.github.com/Dudemanguy911/d70734d5bdf82e79cbfb22894fac8a1b/"
-provides=(gtk2=$pkgver libgailutil.so libg{d,t}k-x11-2.0.so)
+depends=(
+ atk
+ cairo
+ desktop-file-utils
+ gtk-update-icon-cache
+ libcups
+ librsvg
+ libxcomposite
+ libxcursor
+ libxdamage
+ libxi
+ libxinerama
+ libxrandr
+ pango
+ shared-mime-info
+)
+makedepends=(
+ git
+ gobject-introspection
+ gtk-doc
+)
+optdepends=(
+ 'adwaita-icon-theme: Default icon theme'
+ 'gnome-themes-standard: Default widget theme'
+ 'python: gtk-builder-convert'
+)
+provides=(
+ gtk2=$pkgver
+ libgailutil.so
+ libg{d,t}k-x11-2.0.so
+)
conflicts=('gtk2')
-depends=('atk' 'pango' 'libxcursor' 'libxinerama' 'libxrandr' 'libxi' 'libxcomposite' 'libxdamage'
- 'shared-mime-info' 'cairo' 'libcups' 'gtk-update-icon-cache' 'librsvg'
- 'desktop-file-utils' 'gtk-doc')
-makedepends=(gobject-introspection git gtk-doc)
-optdepends=('gnome-themes-standard: Default widget theme'
- 'adwaita-icon-theme: Default icon theme'
- 'python2: gtk-builder-convert')
license=('LGPL')
install=gtk2.install
-_commit=664537d6185800d7603438d4b9e18fbc6256ad41 # gtk-2-24
-source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
- gtkrc
- gtk-query-immodules-2.0.hook
- xid-collision-debug.patch
- gtk2-filechooser-icon-view.patch)
+_commit=68631945733158f164427db84f01301d7e875763 # tags/2.24.33^0
+source=(
+ "git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
+ gtkrc
+ gtk-query-immodules-2.0.hook
+ xid-collision-debug.patch
+ gtk2-filechooser-icon-view.patch
+)
+b2sums=('SKIP'
+ '0583436972edcebb09ce6c3f445f6ea4d7f92132da0ef317ee93665b646061ba261281b0186ed6655e63bbb668c58e37f6987919d4c054ccda19ca034aa718dc'
+ '9c531f9f605e1739e13c39c1cac22daddd9574f3082f18bcf0b9dfaa4c41f2485d55be03a9ed12fb4504d509f0d5ac63980a9d9349e3f80a06595c6430c78096'
+ 'c35b2f16ea3402f41a7a5ac83a93b423e46f9355e11186742402887ba94fc58e9a5c1d7fc55141fab72f230a973c5ac6346090b225a5eff9e416e397bd1b1ec4'
+ '3bfc017cdb94f604b6d211747641cc6564955c0f4108654cea11dc19a574854ee0d56019f34faa577f3b92708a2c7b57b4a1a2146c9d7772bf0a567288be60a6')
-sha256sums=('SKIP'
- 'bc968e3e4f57e818430130338e5f85a5025e21d7e31a3293b8f5a0e58362b805'
- '427e7ed2626465ea7a8986189b6c8340a0520b9f7b8e2a56cd1169d375da7425'
- 'd758bb93e59df15a4ea7732cf984d1c3c19dff67c94b957575efea132b8fe558'
- '91e5c18be6dffc05af41561b38934259494bc14041a9c1d91b0b9b1a1dcd2be5')
+pkgver() {
+ cd gtk
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
+}
prepare() {
cd gtk
- git cherry-pick -n 2dbf31c0ea4f17a817b931c731f8de14c278300d
- patch -Np1 -i ../xid-collision-debug.patch
- patch -Np1 -i $srcdir/gtk2-filechooser-icon-view.patch
- sed -i '1s/python$/&2/' gtk/gtk-builder-convert
+ git apply -3 ../xid-collision-debug.patch
+ git apply -3 ../gtk2-filechooser-icon-view.patch
NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd gtk
-
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-xinput=yes \
+ local configure_options=(
+ --prefix=/usr
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --with-xinput=yes
--disable-gtk-doc
+ )
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ cd gtk
+ ./configure "${configure_options[@]}"
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
make
}
@@ -64,5 +91,8 @@ package() {
install -Dt "$pkgdir/usr/share/gtk-2.0" -m644 ../gtkrc
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../gtk-query-immodules-2.0.hook
+ # Built by GTK 4, shared with GTK 2/3
rm "$pkgdir/usr/bin/gtk-update-icon-cache"
}
+
+# vim:set sw=2 sts=-1 et: