summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 23 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a30c30ed21cc..ff23b9892f7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,10 @@
# vercheck-gnome: name=gtk+, majorver=2.24
pkgname=gtk2-ubuntu
-_ubuntu_rel=4ubuntu1
-_ubuntu_ver=2.24.31
-pkgver=2.24.31
-pkgrel=4
+_ubuntu_rel=1ubuntu1
+_ubuntu_ver=2.24.32
+pkgver=2.24.32
+pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit (legacy)"
arch=(i686 x86_64)
url="http://www.gtk.org/"
@@ -24,20 +24,25 @@ optdepends=('adwaita-icon-theme: Default icon theme'
provides=("gtk2=${pkgver}")
conflicts=(gtk2)
install=gtk2.install
-source=("http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-${pkgver}.tar.xz"
+_commit=ed7d3e25f8b6debae6ccc8b50d1329155338cab8 # tags/2.24.32^0
+source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
"https://launchpad.net/ubuntu/+archive/primary/+files/gtk+2.0_${_ubuntu_ver:-${pkgver}}-${_ubuntu_rel}.debian.tar.xz"
gtkrc
gtk-query-immodules-2.0.hook
xid-collision-debug.patch)
-sha512sums=('75b846661308d94b5236e7e1c367deabf57753792ca87e92f9769822dd5ec90e00cd8d5574adcc12162e3702e1ae6dc152278a1d218f9bd9e4d1c8dc1dd520c1'
- '9fffb60274ee3a2250e4be34f40a526f93d49aacc994b8267f04fc8de9417582d4319385adec91eebe8e6b6215ec9269617140a21a35e1e826b0985ca72236e7'
+sha512sums=('SKIP'
+ '5a82542c2f3d71f10fdc828d846e5a76e85eac7c28314aa865b036b908a8bf14cfe598c6220be7e6f5096cd2a1174051af8b6a97ca9d7d926e0c20289b2c6b4f'
'b124433dd4b20d1d62f073df87e253ca23b3b51625cce55f29a220a4369eda5108c0de07fdc686f570232322c3ff04f7758383f2be5aeace40f843907aa3696d'
'be7a807046f27e5796f6069dfd2c88f9b7508e3b9e209d97c1575e0d809b279aacacd0e1247f1f7643fa47eede2d987bf433cd17cea0524526ad31982ae8d90d'
'89e3223c86731a76b12d39245f1ec4cf8b4860ab1d11d74a10e5deb0db302f20b4bb5d9034da1d8aeb96369dbdeddcdd2f28943270dc501476c694562b960159')
-prepare() {
- cd "gtk+-${pkgver}"
+pkgver() {
+ cd gtk
+ git describe --tags | sed 's/-/+/g'
+}
+prepare() {
+ cd gtk
patch -Np1 -i ../xid-collision-debug.patch
sed -i '1s/python$/&2/' gtk/gtk-builder-convert
@@ -67,14 +72,14 @@ prepare() {
msg "Applying ${i}"
patch -p1 -i "../debian/patches/${i}"
done
+
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "gtk+-${pkgver}"
-
- autoreconf -vfi
+ cd gtk
- CXX=/bin/false ./configure \
+ ./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -89,14 +94,11 @@ build() {
}
package() {
- cd "gtk+-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd gtk
+ make DESTDIR="$pkgdir" install
- install -Dm644 ../gtkrc \
- "${pkgdir}/usr/share/gtk-2.0/gtkrc"
- install -Dm644 ../gtk-query-immodules-2.0.hook \
- "${pkgdir}/usr/share/libalpm/hooks/gtk-query-immodules-2.0.hook"
+ install -Dt "$pkgdir/usr/share/gtk-2.0" -m644 ../gtkrc
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../gtk-query-immodules-2.0.hook
- rm "${pkgdir}/usr/bin/gtk-update-icon-cache"
- rm -r "${pkgdir}/usr/share/gtk-doc"
+ rm "$pkgdir/usr/bin/gtk-update-icon-cache"
}