summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 25 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1dee295a9ca9..ea9cec3bc05d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,22 +10,23 @@
_use_ppa=true
pkgname=gtk3-ubuntu
-_ubuntu_rel=0ubuntu1~ubuntu16.10.1
-pkgver=3.22.2
+_ubuntu_rel=1ubuntu1~ubuntu16.10.1
+pkgver=3.22.4
pkgrel=1
pkgdesc="GObject-based multi-platform toolkit"
arch=(i686 x86_64)
url="http://www.gtk.org/"
install=gtk3.install
-depends=(adwaita-icon-theme at-spi2-atk atk cairo colord desktop-file-utils gdk-pixbuf2 gtk-update-icon-cache json-glib libcups libepoxy librsvg libxcomposite libxcursor libxdamage libxi libxinerama libxkbcommon libxrandr pango rest shared-mime-info wayland wayland-protocols)
-makedepends=(gobject-introspection gtk-doc libcanberra)
-optdepends=('libcanberra: gtk3-widget-factory demo')
+depends=(adwaita-icon-theme at-spi2-atk atk cairo colord desktop-file-utils gdk-pixbuf2 gtk-update-icon-cache json-glib libcups libepoxy librsvg libxcomposite libxcursor libxdamage libxi libxinerama libxkbcommon libxrandr mesa pango rest shared-mime-info wayland wayland-protocols)
+makedepends=(colord git gobject-introspection gtk-doc libcanberra libcups rest)
+optdepends=('libcanberra: gtk3-widget-factory demo'
+ 'gtk3-print-backends: Printing')
provides=("gtk3=${pkgver}")
conflicts=(gtk3)
license=(LGPL)
-source=("https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
- 0001-gdkscreen-x11-Fix-screen-and-monitor-size-calculatio.patch
- settings.ini
+_commit=4569bb372f838a9a68c9b134ef18865abe77001c # tags/3.22.4^0
+source=("git://git.gnome.org/gtk+#commit=${_commit}"
+ settings.ini
gtk-query-immodules-3.0.hook)
if [[ "${_use_ppa}" != "true" ]]; then
@@ -34,16 +35,18 @@ else
source+=("http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu/pool/main/g/gtk+3.0/gtk+3.0_${_ubuntu_ver:-${pkgver}}-${_ubuntu_rel}.debian.tar.xz")
fi
-sha512sums=('edf8c3fa858d87605df1d244d5103a2d4cabbbe3aa4213220342ad84fd595df94fa5526db5b51a3d89bba1e3548d47d9c15dbb68a8ae3bcd99ebfa333797a2ee'
- '6c41ac66f8e3df4ed630f31733b5dd67fe85db79fe713f3b645a8c16e80bf04eaadb0cb05e18d03d26d72eff39db2d534bb247b5c95190381f22f2f3f673f756'
+sha512sums=('SKIP'
'ad2c0b0388f4169592b9574f0b3db673a969b7c4721548c4ac7c438eddbcdc378fcaac04e2b6c858a1562cc23ddf4804e5f7be08068340b7c9365e2b11ddcfb8'
'f0ffd95544863f2e10fda81488b4727aa9a8a35a7d39fb96872db6664d03442db2b58af788b5990825c7b3a83681f7220ca481409cca5421dfb39b9a3bbac9ac'
- '165c881c7195eefabde0d0d99e7ff4553725a4dd12299ff42e96d5eeacc29a0d589ff8cbeec5cbe01599f04dbf94b4082e6da4e7d1fc2cc911c293dc9b6ad31c')
+ '29c3b0369cf81b46843abbda090162da29ae63dca9e54ca32c25b1eea6a55325f2203e71c8af7ad3d7a98bb9c69d4c0d3c9d4bd591eb460ba8b907c745f38863')
-prepare() {
- cd "gtk+-${pkgver}"
+pkgver() {
+ cd gtk+
+ git describe --tags | sed 's/-/+/g'
+}
- patch -p1 -i ../0001-gdkscreen-x11-Fix-screen-and-monitor-size-calculatio.patch
+prepare() {
+ cd gtk+
local patches=(
016_no_offscreen_widgets_grabbing.patch
@@ -51,18 +54,21 @@ prepare() {
060_ignore-random-icons.patch
073_treeview_almost_fixed.patch
074_eventbox_scroll_mask.patch
- no-accessibility-dump.patch
+ no-accessibility-dump.patch
+ reftest-known-fail.patch
bzg_gtkcellrenderer_grabbing_modifier.patch
ubuntu_gtk_custom_menu_items.patch
print-dialog-show-options-of-remote-dnssd-printers.patch
uimanager-guard-against-nested-node-updates.patch
x-canonical-accel.patch
message-dialog-restore-traditional-look-on-unity.patch
+ 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
+ restore_filechooser_typeaheadfind
0001-calendar-always-emit-day-selected-once.patch
0001-gtkwindow-set-transparent-background-color.patch
ubuntu_fileselector_behaviour.patch
- unity-border-radius.patch
- unity-headerbar-maximized-mode.patch
+ unity-border-radius.patch
+ unity-headerbar-maximized-mode.patch
)
for i in "${patches[@]}"; do
@@ -74,7 +80,7 @@ prepare() {
}
build() {
- cd "gtk+-${pkgver}"
+ cd gtk+
CXX=/bin/false ./configure \
--prefix=/usr \
@@ -93,7 +99,7 @@ build() {
}
package() {
- cd "gtk+-${pkgver}"
+ cd gtk+
make DESTDIR="${pkgdir}" install
install -Dm644 ../settings.ini \