summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9538486c734..a8d653fdf96f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,22 @@ _pkgname=gtkcord4
pkgver=0.0.3
pkgrel=1
pkgdesc='Discord client written in go and gtk4, binary release'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url='https://github.com/diamondburned/gtkcord4'
license=('GPL3')
provides=('gtkcord4')
conflicts=('gtkcord4' 'gtkcord4-git')
depends=('gtk4' 'gobject-introspection')
-source=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-x86_64.tar.gz'
- 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
-sha256sums=('SKIP' 'SKIP')
+
+source_x86_64=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-x86_64.tar.gz'
+ 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
+sha256sums_x86_64=('SKIP' 'SKIP')
+
+source_aarch64=('https://github.com/diamondburned/gtkcord4/releases/download/v0.0.3-2/gtkcord4-linux-aarch64.tar.gz'
+ 'gtkcord4.desktop::https://aur.archlinux.org/cgit/aur.git/plain/gtkcord4.desktop?h=gtkcord4-git')
+sha256sums_aarch64=('SKIP' 'SKIP')
package() {
- tar -xzf gtkcord4-linux-x86_64.tar.gz
install -Dm755 gtkcord4 "$pkgdir"/usr/bin/gtkcord4
install -Dm644 "$srcdir/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
}