summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9dd3a1cc7bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgbase=gtksourceview-highlight-rhtml
+pkgname=('gtksourceview2-highlight-rhtml' 'gtksourceview3-highlight-rhtml')
+pkgver=LATEST
+pkgrel=1
+pkgdesc='Embedded Ruby syntax highlighting for gtksourceview'
+arch=('any')
+url=('https://github.com/gmate')
+license=('GPL')
+source=('https://github.com/gmate/gmate/raw/master/lang-specs/rhtml.lang')
+sha512sums=('SKIP')
+
+package_gtksourceview2-highlight-rhtml() {
+ depends=('gtksourceview2' 'gtksourceview2-highlight-rails')
+
+ install -m644 -D rhtml.lang "$pkgdir/usr/share/gtksourceview-2.0/language-specs/rhtml.lang"
+}
+
+package_gtksourceview3-highlight-rhtml() {
+ depends=('gtksourceview3' 'gtksourceview3-highlight-rails')
+
+ install -m644 -D rhtml.lang "$pkgdir/usr/share/gtksourceview-3.0/language-specs/rhtml.lang"
+}
+