summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 232a10b8aa47..b9efdc7ec484 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,24 @@
pkgname=gtksourceview5
pkgver=5.0.0
-pkgrel=2
-pkgdesc="A text widget adding syntax highlighting and more to GNOME"
-url="https://gitlab.gnome.org/GNOME/gtksourceview"
-license=("LGPL")
+pkgrel=3
+pkgdesc='A text widget adding syntax highlighting and more to GNOME'
+url='https://gitlab.gnome.org/GNOME/gtksourceview'
+license=('LGPL')
arch=(x86_64 aarch64)
depends=(gtk4)
makedepends=(
- git
gobject-introspection
-# gtk-doc
+ gtk-doc
meson
vala
)
checkdepends=(xorg-server-xvfb)
-source=("git+https://gitlab.gnome.org/GNOME/gtksourceview.git#tag=${pkgver}")
+source=("${url}/-/archive/${pkgver}/gtksourceview-${pkgver}.tar.gz")
sha256sums=('SKIP')
build() {
- arch-meson gtksourceview build # -D gtk_doc=true
+ arch-meson gtksourceview-${pkgver} build -D gtk_doc=true
meson compile -C build
}