summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 5 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb774f1ad801..b3bfb74217bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Black_Codec <orso.f.regna@gmail.com>
pkgname=guacamole-server
-pkgver=1.4.0
-pkgrel=4
+pkgver=1.5.0
+pkgrel=1
pkgdesc="Guacamole proxy daemon"
arch=('i686' 'x86_64' 'armv7h')
url="http://guacamole.sourceforge.net/"
@@ -22,28 +22,15 @@ optdepends=('libssh: for ssh protocol support'
install=$pkgname.install
source=("http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/${pkgver}/source/${pkgname}-${pkgver}.tar.gz"
- "guacd.conf"
- "https://github.com/apache/guacamole-server/commit/bc6b5cef25cb2c66cb4e0e96df6d2639a61a197a.patch"
- "https://github.com/apache/guacamole-server/commit/9c93337d9781d4d85d84d9442297a2013c492837.patch"
- "https://github.com/apache/guacamole-server/commit/f84db7d166fb76f33b879ae297a1899a12b80b57.patch")
+ "guacd.conf")
backup=('etc/guacamole/guacd.conf')
-md5sums=('b17c6152e96af0488ca4c0608e5ec3ae'
- 'ab0ac97ad76d16be73768f89abb6ee7e'
- 'bd58fffb01f7f6ab9bae306bdbea61ea'
- '5010a8a2982c4ce5453c5a5c8d0a6845'
- '6f9cfb4adce7628b7b5c1dc747934946')
+md5sums=('1577346b5ff8e388ddd12c7983fad955'
+ 'ab0ac97ad76d16be73768f89abb6ee7e')
prepare() {
cd "$srcdir"/$pkgname-$pkgver
- # guacenc doesn't work since ffmpeg 4.4 (av_init_packet() is deprecated) so, we apply this patch
- # Reference: https://github.com/apache/guacamole-server/pull/352/commits/bc6b5cef25cb2c66cb4e0e96df6d2639a61a197a
- patch -Np1 -i ../bc6b5cef25cb2c66cb4e0e96df6d2639a61a197a.patch
-
- # Fix OpenSSL warnings
- patch -Np1 -i ../9c93337d9781d4d85d84d9442297a2013c492837.patch
- patch -Np1 -i ../f84db7d166fb76f33b879ae297a1899a12b80b57.patch
}
build() {