summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b866c5eae5f8..958e41dafc48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Vinícius Moreira <vinicius_fmoreira@hotmail.com>
+# Maintainer: Vinícius Moreira <vinicius_fmoreira at hotmail dot com>
pkgname=guapow-staging
_pkgname=guapow
pkgver=1.3.4.RC
-pkgrel=1
-_commit="a700c88a93dc890db8b228c325cf20a1711d8a3c"
+pkgrel=2
+_commit="a2ee990c61c5d3ba14d8a4c02d07f74fdbbd193b"
pkgdesc="On-demand and auto performance optimizer for Linux applications (testing branch. It may not be working properly)"
arch=('any')
url="https://github.com/vinifmor/guapow"
@@ -12,21 +12,25 @@ license=('zlib/libpng')
depends=('python' 'python-aiofiles' 'python-aiohttp' 'python-pycryptodome' 'systemd')
optdepends=('inxi: guess the window compositor',
'unclutter: required for hiding the mouse cursor')
-makedepends=('git' 'python' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
provides=($_pkgname)
conflicts=($_pkgname)
source=("${url}/archive/${_commit}.tar.gz")
-sha512sums=('ff08e4af6f5ffae0692869506388a37febafd7407f04574b3ae92ce3d5b7f1dc87be43900362f11e240db98902ed38a09320d0feab4ae2b5f4257edc92c95477')
+sha512sums=('e67c0d2a8df7e706da63bca01b1f235a20c02f5838a51e6733b657be82a6ac8c22430b2a02e6ce2c63dcca2f1a606133891b4b11f2a75eb7bc838c84e892a13d')
build() {
cd "${srcdir}/${_pkgname}-${_commit}"
- python3 setup.py build
- python3 setup.py test || return 1
+
+ # removing outdated setup files
+ rm setup.cfg setup.py requirements.txt
+
+ python -m unittest discover -s tests -t tests -v || return 1
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgname}-${_commit}"
- python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
mkdir -p $pkgdir/etc/$_pkgname
cp $_pkgname/dist/daemon/opt.conf $pkgdir/etc/$_pkgname/opt.conf.example