summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adc3ae165120
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+###PKGBUILD was last modified on September 15, 2022 at 03:53 PM EDT by bms###
+# Maintainer: Ben Sutter <benjaminsutter@outlook.com>
+pkgname=guile-colorized-git
+pkgver=v0.1.r5.g1625a79
+pkgrel=1
+pkgdesc="Colorized Guile REPL from Git"
+arch=('any')
+url="https://gitlab.com/NalaGinrut/guile-colorized"
+license=('GPL')
+makedepends=('git' 'sed')
+source=("$pkgname::git+https://gitlab.com/NalaGinrut/guile-colorized.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ sed -i -e "s%^TARGET.\+:= %TARGET := $pkgdir%" -e 's%install:%install:\n mkdir -p \$\(TARGET\)\n%' Makefile
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's%\([^-]*-g\)%r\1%;s%-%.%g'
+}
+
+package() {
+ cd "$pkgname"
+ make install
+}