summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adc3ae165120..2bb08dd5162e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,21 +7,22 @@ pkgdesc="Colorized Guile REPL from Git"
arch=('any')
url="https://gitlab.com/NalaGinrut/guile-colorized"
license=('GPL')
-makedepends=('git' 'sed')
-source=("$pkgname::git+https://gitlab.com/NalaGinrut/guile-colorized.git")
+makedepends=('git' 'sed' 'guile')
+provides=("guile-colorized=$pkgver")
+source=("${pkgname%-git}::git+https://gitlab.com/NalaGinrut/guile-colorized.git")
md5sums=('SKIP')
prepare() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
sed -i -e "s%^TARGET.\+:= %TARGET := $pkgdir%" -e 's%install:%install:\n mkdir -p \$\(TARGET\)\n%' Makefile
}
pkgver() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
git describe --long | sed 's%\([^-]*-g\)%r\1%;s%-%.%g'
}
package() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
make install
}