summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 290876837825..679921e13fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
-# Maintainer: Brian Bidulock <bidulock@openss7.org>
-# Contributor: tantalum <tantalum at online dot de>
+# contributor: tantalum <tantalum at online dot de>
pkgname=guile-lib
pkgver=0.2.2
-pkgrel=2
+pkgrel=1
pkgdesc='Repository of useful code written in Guile Scheme'
-arch=('i686' 'x86_64')
-license=('GPL3' 'LGPL3')
-depends=('guile')
-url="http://www.nongnu.org/guile-lib/"
-install=$pkgname.install
+arch=(i686 x86_64)
+license=("GPL3 and LGPL3")
+depends=(guile)
+url=http://www.nongnu.org/guile-lib/
source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('77427e4ff3f2b1061bffa370666125f7')
-
+md5sums=(77427e4ff3f2b1061bffa370666125f7)
build(){
- cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr
- make
-}
+ cd ${srcdir}/${pkgname}-${pkgver} &&
+
+ ./configure --prefix=/usr || return 1
+ make && make DESTDIR=${pkgdir} install || return 1
-package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
- rm -f "${pkgdir}/usr/share/info/dir"
+ #remove documentation
+ if [ -e ${pkgdir}/usr/share/info/dir ]; then
+ rm ${pkgdir}/usr/share/info/dir
+ fi
}