summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 34 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c739836b08e8..c66e9d57c50b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,54 @@
# Maintainer: Michiru Saito <urihcim at gmail dot com>
pkgname=gura
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="An iterator-oriented programming language"
arch=('i686' 'x86_64')
url='http://www.gura-lang.org/'
license=('unknown')
+_moddepends=('bzip2'
+ 'cairo'
+ 'curl'
+ 'freetype2'
+ 'fftw'
+ 'glu'
+ 'freeglut'
+ 'gmp'
+ 'zlib'
+ 'libjpeg-turbo'
+ 'alsa-lib'
+ #'liblinear'
+ #'libsvm'
+ 'libgl'
+ 'mesa'
+ 'libpng'
+ 'oniguruma'
+ 'sdl'
+ 'sdl2'
+ 'sqlite'
+ #'tcl'
+ #'tk'
+ 'libtiff'
+ 'wxgtk3'
+ 'expat'
+ 'libyaml')
depends=('readline')
-makedepends=('cmake'
- 'make'
- 'gcc'
- 'bzip2'
- 'cairo'
- 'curl'
- 'freetype2'
- 'fftw'
- 'glu'
- 'freeglut'
- 'gmp'
- 'zlib'
- 'libjpeg-turbo'
- 'alsa-lib'
- #'liblinear'
- #'libsvm'
- 'libgl'
- 'mesa'
- 'libpng'
- 'oniguruma'
- 'sdl'
- 'sdl2'
- 'sqlite'
- #'tcl'
- #'tk'
- 'libtiff'
- 'wxgtk2'
- 'expat'
- 'libyaml')
+makedepends=('cmake' 'make' 'gcc' ${_moddepends[@]})
+optdepends=(${_moddepends[@]})
source=("https://github.com/gura-lang/gura/releases/download/v${pkgver}/gura-${pkgver}-src.tar.gz"
"Value.h.patch"
- "build-modules.gura.patch")
+ "build-modules.gura.patch"
+ "wxgtk3.patch")
md5sums=('5aeb3b21a5f78bd13c2d0940f1ed31d2'
'ef277211f12747b5504e73f011c8cb9c'
- '53597e9ab12a52468e010d2a1caa1262')
+ '53597e9ab12a52468e010d2a1caa1262'
+ '8f6697c526c0308a502edd6fc634177c')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}/Value.h.patch"
patch -p1 -i "${srcdir}/build-modules.gura.patch"
+ patch -p1 -i "${srcdir}/wxgtk3.patch"
}
build() {