summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdf2734328e1..42a769296ce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# http://packages.gentoo.org/package/sci-visualization/gwyddion
pkgname=gwyddion
-pkgver=2.54
+pkgver=2.55
pkgrel=1
pkgdesc="A data visualization and processing tool for scanning probe miscroscopy (SPM, i.e. AFM, STM, MFM, SNOM/NSOM, ...) and profilometry, useful also for general image and 2D data analysis"
url="http://gwyddion.net/"
@@ -22,12 +22,15 @@ optdepends=('libxml2: import of SPML and APE DAX data files'
'libzip: import of APE DAX, NanoObserver, NanoScanTech, OpenGPS and Sensofar PLUX data files'
'cfitsio: import of Flexible Image Transport System (FITS) files'
'openexr: import and export of OpenEXR HDR images')
-source=(http://downloads.sourceforge.net/sourceforge/gwyddion/$pkgname-$pkgver.tar.xz)
-sha256sums=('3713e7f25bfab2e210a89accdfb40e199f2a5d908ee29796afcc8c4c1e9b5ecb')
+source=(http://downloads.sourceforge.net/sourceforge/gwyddion/$pkgname-$pkgver.tar.xz gwyddion-2.55-xml.patch)
+sha256sums=('b1f1fe5ade7d667d005078f25c1b8b1523d18307ac451176ccd7c6b7bffe0050'
+ 'b6e70a95d999e6c9eb419b91695f0e31f43f4248f08e40aa178662e203a5b445')
prepare() {
cd $pkgname-$pkgver
+ patch -Np2 -i "${srcdir}/gwyddion-2.55-xml.patch"
+
# python2 fix
for file in $(find . -name '*.py' -print); do
sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file