summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11df77aa28af..afa8bc5e5165 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,37 @@
# Maintainer: Jakub "Kubuxu" Sztandera <kubuxu@protonmail.ch>
# vim: set expandtab ts=2 sw=2:
-pkgname=gx-go
-pkgver=1.3.0.r0.g3cbfcbb
+_pkgname=gx-go
+pkgname=$_pkgname-git
+pkgver=latest
pkgrel=1
epoch=
pkgdesc="A tool to use with the gx package manager for packages written in go."
arch=('i686' 'x86_64' 'armv7h')
-url="https://github.com/whyrusleeping/$pkgname"
+url="https://github.com/whyrusleeping/$_pkgname"
license=('MIT')
depends=('gx')
+conflicts=('gx-go')
makedepends=('git' 'go')
source=("git+${url}.git")
md5sums=('SKIP')
pkgver() {
# Renable after tags are placed in the repo.
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
mkdir -p "$srcdir"/src/github.com/whyrusleeping/
- ln -fs "$srcdir/$pkgname" "$srcdir"/src/github.com/whyrusleeping/"$pkgname"
+ ln -fs "$srcdir/$_pkgname" "$srcdir"/src/github.com/whyrusleeping/"$_pkgname"
}
build() {
# Required for go get
export GOPATH="$srcdir"
export GOBIN="$GOPATH/bin"
- cd "$srcdir"/src/github.com/whyrusleeping/"$pkgname"
+ cd "$srcdir"/src/github.com/whyrusleeping/"$_pkgname"
msg2 'Installing dependencies...'
go get -v
@@ -43,6 +45,6 @@ package() {
install -Dm 755 bin/gx-go "${pkgdir}/usr/bin/gx-go"
msg2 'Packaging auxiliary files...'
- cd "$pkgname"
+ cd "$_pkgname"
install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}