summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75c24b9c7eea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gxr
+pkgver=0.12.1
+pkgrel=1
+pkgdesc="glib wrapper for the OpenVR and soon the OpenXR API"
+arch=('i686' 'x86_64')
+url="https://gitlab.freedesktop.org/xrdesktop/gxr"
+license=('MIT')
+depends=('glibc' 'glib2' 'gtk3' 'gulkan' 'openvr')
+makedepends=('meson')
+optdepends=('glfw')
+source=("https://gitlab.freedesktop.org/xrdesktop/gxr/-/archive/$pkgver/gxr-$pkgver.tar.bz2")
+sha256sums=('8d53188b0e6927961b2109096c6bd0124161fbfa1907d2a53a7c12ba965f6ab9')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ meson \
+ --buildtype=plain \
+ --prefix="/usr" \
+ --sbindir="bin" \
+ "_build"
+ ninja -C "_build"
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+
+ #meson test -C "_build"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ DESTDIR="$pkgdir" meson install -C "_build"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/gxr"
+}