summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4c40eedde31..4d1359501554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ if [[ "$CARCH" == x86_64 ]]; then
fi
pkgname=gzdoom-git
-pkgver=20130829
+pkgver=1.9pre.r605.gcd6d653
pkgrel=1
pkgdesc="Doom source port based on ZDoom with an OpenGL renderer (git version)."
arch=('i686' 'x86_64')
@@ -50,7 +50,8 @@ _libdir=/usr/lib/gzdoom
_sharedir=/usr/share/games/gzdoom
pkgver() {
- date +%Y%m%d
+ cd gzdoom
+ git describe --long --tags --match 'G*' | sed -r 's/^G//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {