summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eeae00bee38d..63771568db3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=hackgregator
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc="This application is a comfortable reader application for news.ycombinator.com"
arch=('x86_64')
url="https://gitlab.com/gunibert/hackgregator"
license=('GPL3')
-depends=('glib2' 'gtk3' 'libhandy' 'libsoup' 'json-glib' 'webkit2gtk')
-makedepends=('git' 'gobject-introspection' 'meson' 'ninja')
+depends=('glib2' 'libadwaita' 'libsoup3' 'json-glib' 'webkit2gtk-5.0')
+makedepends=('meson' 'cargo')
checkdepends=('appstream-glib')
source=($url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('577a9f0d2185d67c14e2fd26a7ecec15a4512b693253198c68a31c132f621426')
+b2sums=('d25a9561bf3cd89da54a782feb4674f6b8cd42a1f9ea104aa81f00f2c94976ea715820d203896ea526be3a6a9739e3893f335356436cbe564926a6e2600b35f9')
build() {
arch-meson $pkgname-$pkgver build
@@ -19,9 +19,9 @@ build() {
}
check() {
- meson test -C build --print-errorlogs
+ meson test -C build
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}