summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66e8c293d4fd..611b3f843e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer: Stephen Brandt <stephen@stephenbrandt.com>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=haguichi
-pkgver=1.3.7
+pkgver=1.3.8
pkgrel=1
pkgdesc="Provides a user friendly GUI to control the Hamachi client on Linux"
-arch=('x86_64' 'i686' 'arm' 'armv7h')
-url="http://www.haguichi.net"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+url="https://www.haguichi.net"
license=('GPL3')
depends=('gtk3' 'libnotify' 'logmein-hamachi')
-makedepends=('cmake' 'vala')
+makedepends=('meson' 'vala')
source=("http://launchpad.net/$pkgname/${pkgver%.*}/$pkgver/+download/$pkgname-$pkgver.tar.xz")
-sha256sums=('e769b81a8de9932ea42d0a21431e6c1440ef638472d68ab2d5bebab9c728cfbc')
+sha256sums=('b5834b1ed4a9e578e3f0b98ff27db7ca9e458cd2cf0d810bbd470bfbfe20141e')
prepare() {
cd $pkgname-$pkgver
@@ -22,10 +23,10 @@ prepare() {
build() {
cd $pkgname-$pkgver/build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DICON_UPDATE=OFF -DGSETTINGS_COMPILE=OFF
- make
+ meson ..
+ ninja
}
package() {
- make -C $pkgname-$pkgver/build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C $pkgname-$pkgver/build install
}