summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 611b3f843e4d..bc6a977c7be1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=haguichi
-pkgver=1.3.8
+pkgver=1.4.0
pkgrel=1
pkgdesc="Provides a user friendly GUI to control the Hamachi client on Linux"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
url="https://www.haguichi.net"
license=('GPL3')
-depends=('gtk3' 'libnotify' 'logmein-hamachi')
+depends=('gtk3' 'libappindicator-gtk3' 'libnotify' 'logmein-hamachi')
makedepends=('meson' 'vala')
+replaces=('haguichi-indicator')
source=("http://launchpad.net/$pkgname/${pkgver%.*}/$pkgver/+download/$pkgname-$pkgver.tar.xz")
-sha256sums=('b5834b1ed4a9e578e3f0b98ff27db7ca9e458cd2cf0d810bbd470bfbfe20141e')
+sha256sums=('0cf56ff900dc39f4c115a6a86361cc4c2743cc7a180769f2f4446ad3315f5d0f')
prepare() {
cd $pkgname-$pkgver
@@ -23,7 +24,7 @@ prepare() {
build() {
cd $pkgname-$pkgver/build
- meson ..
+ meson -Denable-appindicator=true ..
ninja
}