summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f80ec9683a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Samuel Sloniker <sam@kj7rrv.com>
+
+pkgname=hamclock-bigger
+pkgver=2.68
+pkgrel=2
+epoch=
+pkgdesc="Clock and world map with extra features for amateur radio (2400x1440 version)"
+arch=('x86_64')
+url="https://clearskyinstitute.com/ham/HamClock"
+license=('MIT')
+groups=()
+depends=('libx11' 'libxcb')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=('hamclock')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/kj7rrv/hamclock/archive/refs/tags/v$pkgver.tar.gz")
+noextract=()
+sha256sums=('ac9fb741161d34c1385db2e4471fb9484a91e4b652e407db4ee545611b2d3c3f')
+validpgpkeys=()
+
+prepare() {
+ cd "hamclock-$pkgver/ESPHamClock"
+ # Add -AUR to version
+ sed -i 's/"/-AUR"/g' version.h
+ sed -i 's/\t-AUR"/\t"/g' version.h
+
+ # Do not check for/install updates
+ sed -i "s/tft.print (F(\"You're up to date\!\"));"'/tft.print(F("Updates disabled for AUR")); tft.setCursor (tft.width()\/8, tft.height()\/3+40); tft.print(F("If this build is outdated by more than a few days,")); tft.setCursor (tft.width()\/8, tft.height()\/3+80); tft.print(F("please email sam@kj7rrv.com.")); wdDelay(2000);/g' ESPHamClock.ino
+ sed -i 's/bool found_newer = false;/return false;bool found_newer;/g' OTAupdate.cpp
+}
+
+build() {
+ cd "hamclock-$pkgver/ESPHamClock"
+ make -j 4 hamclock-2400x1440
+}
+
+package() {
+ cd "hamclock-$pkgver/ESPHamClock"
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/share/applications" "$pkgdir/usr/share/icons"
+ cp hamclock-2400x1440 "$pkgdir/usr/bin/hamclock"
+ cp hamclock.png "$pkgdir/usr/share/icons"
+ cat > "$pkgdir/usr/share/applications/hamclock.desktop" << HERE
+[Desktop Entry]
+Name=HamClock
+Exec=hamclock
+Icon=/usr/share/icons/hamclock.png
+Terminal=false
+Type=Application
+Categories=HamRadio
+HERE
+}