summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 9 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9672d1cc8f40..8f062ad883c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,42 +4,18 @@
# Contributor: Sebastien Piccand <sebcactus gmail com>
pkgname=('handbrake-fdkaac' 'handbrake-cli-fdkaac')
-pkgver=1.0.0
-pkgrel=4
+pkgver=1.0.1
+pkgrel=1
arch=('i686' 'x86_64')
url="https://handbrake.fr/"
license=('GPL')
makedepends=('intltool' 'python2' 'yasm' 'wget' 'bzip2' 'gcc-libs' 'libnotify'
'gst-plugins-base' 'gtk3' 'dbus-glib' 'fribidi' 'libass' 'lame'
'fontconfig' 'freetype2' 'libxml2' 'libogg' 'libvorbis' 'cmake'
- 'libtheora' 'libsamplerate' 'ffmpeg' 'x264' 'libx264' 'x265'
- 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev' 'libfdk-aac')
-source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2
- handbarke-fix-crash-during-2-pass-encode.patch
- handbrake-fix-2-pass-vp8-and-vp9-encoding.patch
- handbrake-fix-missing-x265-link-flag.patch)
-sha256sums=('15fb4593c70d75621212e4499f018c3c93d7ce39f1083bf527d4616ded0044c5'
- 'aaa09e9b3dbad54024f02afe8ace5390b281c7cc6aae80cf26d43f773b2d19f7'
- '1b6d800acde0cc2c7e6080f23f2ddd435257c5a2d853acdeb4e4a6fada856310'
- '05e212e76b6e0b94a04de02cbeb7bf9db607059e19297b5bd3d0d143135285c4')
-
-prepare() {
- cd "$srcdir/HandBrake-$pkgver"
-
- # https://github.com/HandBrake/HandBrake/commit/e159ab1662ba#commitcomment-20303756
- patch -Np1 -i ../handbarke-fix-crash-during-2-pass-encode.patch
- # https://github.com/HandBrake/HandBrake/issues/449#issuecomment-269352579
- patch -Np1 -i ../handbrake-fix-2-pass-vp8-and-vp9-encoding.patch
-
- # https://bugs.gentoo.org/show_bug.cgi?id=552792
- patch -Np1 -i ../handbrake-fix-missing-x265-link-flag.patch
-
- # Use more system libs
- # Bundled libbluray is kept because it is patched locally
- for _lib in ffmpeg x265 libvpx libdvdnav libdvdread; do
- sed -i "/MODULES += contrib\/$_lib/d" make/include/main.defs
- done
-}
+ 'libtheora' 'libsamplerate' 'x264' 'libx264' 'jansson' 'librsvg'
+ 'libgudev')
+source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2)
+sha256sums=('af4badcdf56465abc798e5e11fe0e437e23ea89bbee20798408980a34c4d5876')
build() {
cd "$srcdir/HandBrake-$pkgver"
@@ -56,9 +32,8 @@ package_handbrake-fdkaac() {
conflicts=('handbrake')
depends=('bzip2' 'gcc-libs' 'gst-plugins-base' 'libnotify' 'dbus-glib'
'fribidi' 'libass' 'lame' 'gtk3' 'fontconfig' 'freetype2' 'libxml2'
- 'libogg' 'libvorbis' 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264'
- 'x265' 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev'
- 'desktop-file-utils' 'hicolor-icon-theme' 'libfdk-aac')
+ 'libogg' 'libvorbis' 'libtheora' 'libsamplerate' 'libx264' 'jansson'
+ 'librsvg' 'libgudev' 'desktop-file-utils' 'hicolor-icon-theme')
optdepends=('gst-plugins-good: for video previews'
'gst-libav: for video previews')
@@ -72,8 +47,7 @@ package_handbrake-cli-fdkaac() {
pkgdesc="Multithreaded video transcoder (CLI)"
conflicts=('handbrake-cli')
depends=('bzip2' 'gcc-libs' 'zlib' 'fribidi' 'libass' 'lame' 'libxml2'
- 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264' 'x265' 'libvpx'
- 'libdvdnav' 'jansson' 'libfdk-aac')
+ 'libtheora' 'libsamplerate' 'libx264' 'jansson')
cd "$srcdir/HandBrake-$pkgver/build"
install -D HandBrakeCLI "$pkgdir/usr/bin/HandBrakeCLI"