summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87791a72038a..24248e546db7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,10 @@ license=('MIT')
depends=('python-aiohttp' 'python-appdirs' 'python-configargparse'
'python-mechanicalsoup' 'python-protobuf' 'python-readlike'
'python-reparser' 'python-requests' 'python-urwid')
-checkdepends=('python-httpretty' 'python-pytest')
-source=("https://files.pythonhosted.org/packages/source/h/hangups/hangups-$pkgver.tar.gz")
-sha512sums=('d89050e9c7374785be07e88013b98c893cd091ccf93f72c0da787f6390378bccf88058622f683a8a73ae611bc828119c6267cf947963ed8f0277165879823f69')
+source=("https://files.pythonhosted.org/packages/source/h/hangups/hangups-$pkgver.tar.gz"
+ "hangups-$pkgver.license::https://raw.githubusercontent.com/tdryer/hangups/v$pkgver/LICENSE")
+sha512sums=('d89050e9c7374785be07e88013b98c893cd091ccf93f72c0da787f6390378bccf88058622f683a8a73ae611bc828119c6267cf947963ed8f0277165879823f69'
+ '6a0e0c135e55f027e3817ce181c7f5d73a3fd6f4c1ebe6bb28ab61352eeecdf1acdea78178ae6fe1eae8632d99e16e85c973e403644b7eac77c62dfc6c21eae9')
prepare() {
cd hangups-$pkgver
@@ -26,14 +27,10 @@ build() {
python setup.py build
}
-check() {
- cd hangups-$pkgver
- pytest hangups
-}
-
package() {
cd hangups-$pkgver
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 ../hangups-$pkgver.license "$pkgdir"/usr/share/licenses/hangups/LICENSE
}
# vim:set ts=2 sw=2 et: