summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50a093016558..158a6613d22f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
-# Maintainer: Robert Orzanna <orschiro@gmail.com>
+# Maintainer: Pedro Gabriel <pedrogabriel@dcc.ufmg.br>
+# Contributor: Robert Orzanna <orschiro@gmail.com>
pkgname=hardcode-fixer-git
-pkgver=v0.8.2.r10.g58a4851
+pkgver=r395.a01f915
pkgrel=1
pkgdesc="Fixes Hardcoded Icons"
arch=('i686' 'x86_64')
url="https://github.com/Foggalong/hardcode-fixer"
license=('GPL')
-#depends=('pacman' 'curl')
makedepends=('git')
source=("$pkgname"::'git://github.com/Foggalong/hardcode-fixer.git')
-#source=('git+https://github.com/Foggalong/hardcode-fixer.git'
-#source=('git+https://github.com/Foggalong/hardcode-fixer.git#branch=master'
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
package() {