summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da61fc2603eb..896c4de8e67b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thibaut Sautereau (thithib) <thibaut at sautereau dot fr>
pkgname=hardened_malloc
-pkgver=1
+pkgver=2
pkgrel=1
pkgdesc="Hardened allocator designed for modern systems"
arch=('x86_64')
@@ -11,19 +11,19 @@ depends=('python' 'bash')
conflicts=('hardened-malloc-git')
source=("https://github.com/GrapheneOS/$pkgname/archive/$pkgver.tar.gz"
'preload.sh')
-sha256sums=('4a0d496199af491c92a964729e61b11a844c5699082e4158632e71935d5a73fc'
+sha256sums=('4b6e19374457b90f8cdfdc2e3590795355f43adb5fb29f0ba786c562e826547f'
'e6dbce7ac1d689fafbc94ffb17d8c4ae5271dd3580421828d35aac2c067b652d')
build() {
- cd "$pkgname-$pkgver"
- make
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 --target-directory="$pkgdir/usr/lib" libhardened_malloc.so
- install -Dm755 "$srcdir/preload.sh" "$pkgdir/usr/bin/hardened-malloc-preload"
- install -Dm755 calculate_waste.py "$pkgdir/usr/bin/hardened-malloc-calculate-waste.py"
+ cd "$pkgname-$pkgver"
+ install -Dm755 --target-directory="$pkgdir/usr/lib" libhardened_malloc.so
+ install -Dm755 "$srcdir/preload.sh" "$pkgdir/usr/bin/hardened_malloc_preload"
+ install -Dm755 calculate_waste.py "$pkgdir/usr/bin/hardened_malloc_calculate_waste.py"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}