summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..381a3bf08ba4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=hardlinkpy-hg
+pkgver=0.1be1ba7ea389
+pkgrel=1
+pkgdesc='a tool to hardlink together identical files in order to save space'
+arch=('any')
+url='https://code.google.com/p/hardlinkpy/'
+license=('GPL2')
+depends=('python2')
+makedepends=('mercurial')
+provides=('hardlinkpy')
+conflicts=('hardlinkpy')
+source=('hg+https://code.google.com/p/hardlinkpy/')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd hardlinkpy/
+
+ hg tip | head -n1 | tr -d ' ' | cut -d: --output-delimiter=. -f 2,3
+}
+
+package() {
+ cd hardlinkpy/
+
+ sed -i '1c #!/usr/bin/python2' hardlink.py
+
+ install -D -m0755 hardlink.py "${pkgdir}/usr/bin/hardlink.py"
+ install -D -m0644 COPYING "${pkgdir}/usr/share/licenses/hardlinkpy/COPYING"
+}
+