aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d44c398502dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Savvy Raghuvanshi <sraghuvanshi at college dot harvard dot edu>
+
+pkgname=harvard-linux-printer
+pkgver=15.30afe11
+pkgrel=1
+pkgdesc="Connect to Harvard University's printer network from an Arch Linux machine."
+arch=('any')
+url="https://github.com/djsavvy/harvard-linux-printer"
+license=('MIT')
+depends=('cups' 'samba' 'smbclient' 'bash')
+makedepends=('git' 'coreutils')
+optdepends=('gtk3-print-backends: to print from GTK3 applications')
+source=("git://github.com/djsavvy/harvard-linux-printer#branch=aur-package")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo "$(git rev-list --count HEAD).$(git describe --always)" | sed -e 's/-/_/g'
+}
+
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+}