summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bca6d3f2b31..6dd270558924 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,15 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
-# for more information on packaging from GIT sources.
-
-# Maintainer: Your Name <youremail@domain.com>
pkgname=hashcat-utils-git
pkgver=1.2.r1.g9135127
-pkgrel=1
+pkgrel=2
pkgdesc="Hashcat-utils are a set of small utilities that are useful in advanced password cracking."
arch=('i686' 'x86_64')
url="https://github.com/hashcat/hashcat-utils"
license=('MIT')
groups=()
-depends=()
+depends=('perl')
makedepends=('git' 'make')
provides=('hashcat-utils')
-conflicts=()
+conflicts=('hashcat-utils')
replaces=()
backup=()
options=()
@@ -39,6 +30,7 @@ build() {
cd "$srcdir/$_gitname/src"
make linux
+ strip *.bin
}
package() {
@@ -56,6 +48,15 @@ package() {
mv $i ${i%.*}
done
+ cd "$srcdir/$_gitname/src"
+
+ cp ./*.pl "$pkgdir/usr/bin"
+
+ for i in $(ls "." | grep -E "\.pl$")
+ do
+ chmod +x $i
+ done
+
}
# vim:set ts=2 sw=2 et: