summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5eec6ae40669..43f82e68e457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,23 @@
_hkgname=ghc-exactprint
pkgname=haskell-ghc-exactprint
pkgver=0.5.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Using the API Annotations available from GHC 7.10.2, this library provides a means to round trip any code that can be compiled by GHC, currently excluding lhs files."
arch=('i686' 'x86_64')
url="https://hackage.haskell.org/package/${_hkgname}"
license=("custom:BSD3")
depends=("ghc>=7.10.2"
- "haskell-diff"
- "haskell-filemanip"
- "haskell-free"
"haskell-ghc-paths>=0.1"
- "haskell-hunit"
"haskell-mtl>=2.2.1"
"haskell-syb>=0.5"
- "haskell-temporary"
- "haskell-text>=1.2.2"
- "haskell-turtle>=1.3.0")
-options=('strip')
+ "haskell-free>=4.12")
source=("https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz")
sha256sums=('d39a76c0659290075adb053c22fe4147c395a8e29f512008b16de418039aeece')
build() {
cd "${srcdir}/${_hkgname}-${pkgver}"
- runhaskell Setup configure -O --enable-library-profiling --enable-shared \
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
--libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
@@ -47,4 +40,7 @@ package() {
runhaskell Setup copy --destdir="${pkgdir}"
install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+
+ # Remove static libs
+ find "$pkgdir"/usr/lib -name "*.a" -delete
}