summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 33 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e6ac2847981..0c55a86ac346 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,50 @@
-# Maintainer: Damien Flament <damien.flament at gmx dot com>
-# Maintainer: Reed Mullanix <reedmullanix at gmail dot com>
+# Maintainer: Poscat <poscat At mail Dot poscat Dot moe>
-_pkgname=haskell-ide-engine
-pkgname=${_pkgname}-git
-pkgver=r1757.59d5d30
+
+pkgname=haskell-ide-engine-git
+pkgver=r3043.38a6febb
pkgrel=1
-pkgdesc="The engine for Haskell ide-integration. Not an IDE."
-arch=('i686' 'x86_64')
+pkgdesc="The engine for haskell ide-integration. Not an IDE"
+arch=('x86_64')
url="https://github.com/haskell/haskell-ide-engine"
license=('custom:BSD3')
-depends=()
+provides=('haskell-ide-engine')
makedepends=('git' 'stack' 'cabal-install' 'happy')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("git://github.com/haskell/${_pkgname}.git")
+source=("${pkgname}::git://github.com/haskell/haskell-ide-engine.git")
noextract=()
md5sums=('SKIP')
-validpgpkeys=()
+
+# supported are '8.2.2' '8.4.2' '8.4.3' '8.4.4' '8.6.1' '8.6.2' '8.6.3' '8.6.4'
+# '8.6.5' activated by default are the ones also used in a stackage snapshot
+# removing versions you do not use will greatly reduce the compilation time of
+# this package
+
+_enabled_ghc_versions=('8.2.2' '8.4.3' '8.4.4' '8.6.3' '8.6.4' '8.6.5')
pkgver() {
- cd "${srcdir}/${_pkgname}"
-
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd "${srcdir}/${_pkgname}"
-
- git submodule update --init
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git submodule update --init
+}
- stack --stack-yaml=stack-8.2.1.yaml build
- stack --stack-yaml=stack-8.2.2.yaml build
- stack --stack-yaml=stack-8.4.2.yaml build
- stack --stack-yaml=stack-8.4.3.yaml build
+build() {
+ cd "${srcdir}/${pkgname}"
+ for ver in "${_enabled_ghc_versions[@]}"; do
+ stack --stack-yaml=stack-${ver}.yaml build
+ done
}
package() {
- cd "${srcdir}/${_pkgname}"
-
- install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
-
- stack --stack-yaml=stack-8.2.1.yaml --local-bin-path "${pkgdir}/usr/bin/" install \
- && mv "${pkgdir}/usr/bin/hie" "${pkgdir}/usr/bin/hie-8.2.1"
- stack --stack-yaml=stack-8.2.2.yaml --local-bin-path "${pkgdir}/usr/bin/" install \
- && mv "${pkgdir}/usr/bin/hie" "${pkgdir}/usr/bin/hie-8.2.2"
- stack --stack-yaml=stack-8.4.2.yaml --local-bin-path "${pkgdir}/usr/bin/" install \
- && mv "${pkgdir}/usr/bin/hie" "${pkgdir}/usr/bin/hie-8.4.2"
- stack --stack-yaml=stack-8.4.3.yaml --local-bin-path "${pkgdir}/usr/bin/" install \
- && cp "${pkgdir}/usr/bin/hie" "${pkgdir}/usr/bin/hie-8.4.3"
-}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ for ver in "${_enabled_ghc_versions[@]}"; do
+ stack --stack-yaml=stack-${ver}.yaml --local-bin-path "${pkgdir}/usr/bin/" install \
+ && mv "${pkgdir}/usr/bin/hie" "${pkgdir}/usr/bin/hie-${ver}"
+ done
+}