summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f95a984575b2..df761d6c7d9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
pkgname='hastebin'
-pkgver=1.0
+release='1.1'
+pkgver="${release}.0"
pkgrel=1
pkgdesc='Upload data to hastebin.com via stdin'
license=('GPL2')
@@ -7,13 +8,15 @@ url='https://github.com/kevr/hastebin'
arch=('any')
depends=('python' 'python-requests')
-source=('hastebin')
+conflicts=("${pkgname}-git")
+optdepends=('xclip: default --clip-command')
+source=("${url}/archive/${release}.tar.gz")
sha256sums=(
- 'b2ac5a7a8fab997e0b9454fcd54eaf8d3fc2a937bcca8bd2605d2bdd6a04a789'
+ '3224443261007c4a933bcda1a3cad5d050d3ea622a23d4043d3abfd714e66f45'
)
package()
{
- install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}-${release}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}