summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 604192d96b46..3b76f9f24196 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,26 @@
# Maintainer: Erazem Kokot <contact at erazem dot eu>
pkgname='hblock'
-pkgver=2.0.0
+pkgver=2.0.4
pkgrel=1
pkgdesc='An adblocker that creates a hosts file from automatically downloaded blacklists'
arch=('any')
url='https://github.com/hectorm/hblock'
license=('MIT')
-sha256sums=('fc2d59f38d3db4c1d39def1f2360299472ae209fb1d60b28121d8727d38bf7a8')
-source=("https://raw.githubusercontent.com/hectorm/${pkgname}/v${pkgver}/${pkgname}")
+sha256sums=('5363ed1aa7c9acb798591949f516d122e8d40100ae87055bfdba937c6c9bf108')
+source=("https://github.com/hectorm/${pkgname}/archive/v${pkgver}.tar.gz")
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ make -k check
+}
package() {
- install -Dm755 "${pkgname}" "${pkgdir}/usr/local/bin/${pkgname}"
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
}