summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a3c49b53858..b7368863056e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=hcc-git
-pkgver=r7685.e8488139
+pkgver=r7687.4fc4913a
pkgrel=1
pkgdesc="C++ Compiler for Heterogeneous Compute"
url="https://github.com/RadeonOpenCompute/hcc"
@@ -10,14 +10,26 @@ makedepends=(git cmake rocr-runtime)
provides=('hcc')
conflicts=('hcc')
_name=hcc
-source=("git+https://github.com/RadeonOpenCompute/hcc.git")
-sha256sums=("SKIP")
+source=("git+https://github.com/RadeonOpenCompute/hcc.git"
+ "git+https://github.com/RadeonOpenCompute/llvm-project.git"
+ "git+https://github.com/RadeonOpenCompute/ROCm-Device-Libs.git")
+sha256sums=("SKIP"
+ "SKIP"
+ "SKIP")
pkgver() {
cd "$_name"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${_name}"
+ git submodule init
+ git config submodule.llvm-project.git.url "${srcdir}/llvm-project"
+ git config submodule.ROCm-Device-Libs.git.url "${srcdir}/rocdl"
+ git submodule update
+}
+
build() {
cd "${srcdir}/${_name}"
@@ -27,8 +39,7 @@ build() {
cd "${srcdir}/${_name}/build"
cmake .. -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/opt/rocm/hcc"
make
}