summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a8c7449c3ba..58fb7672c85b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: AnnikaV9 <carrot.moncher@gmail.com>
pkgname=hcclient-latex
-pkgver=1.18.3
-pkgrel=2
+pkgver=1.18.4
+pkgrel=1
pkgdesc="A terminal client for hack.chat, with LaTeX support"
arch=("x86_64")
url="https://github.com/AnnikaV9/hcclient"
@@ -12,13 +12,15 @@ conflicts=("hcclient")
depends=("python")
makedepends=("python-pip" "python-wheel")
source=("v${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('a8d36fa7f18fff156ce34d6b5d7c1a6b1bdb89a8a62e73ff804bec01d9b0cd6c')
+sha256sums=('41140c9bbebf4571c410af485c0c524157d4bf51c08bd6197666af9ff09cea91')
build() {
cd "${srcdir}/hcclient-${pkgver}"
RELEASE_VERSION=true NO_ANSI=true bash scripts/build.sh
python -m venv venv
./venv/bin/pip install --disable-pip-version-check --no-color dist/hcclient-${pkgver}-py3-none-any.whl[latex]
+ ./venv/bin/pip uninstall setuptools pip -y --quiet
+ rm venv/bin/{activate*,Activate*}
}
package() {