summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 17 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d304616df788..61d31c083c9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,30 @@
# Contributor: richli
pkgname=hdf-eos5
-pkgver=1.15
-pkgrel=5
-pkgdesc="The HDF-EOS is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library."
+pkgver=1.16
+pkgrel=1
+pkgdesc="The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library."
url="http://www.hdfeos.org/software/library.php"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('szip' 'hdf5-cpp-fortran' 'gdal' 'hdf-eos-common')
+depends=('libaec' 'hdf5_18' 'gdal' 'hdf-eos-common')
options=('libtool' 'staticlibs')
source=(ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.$pkgver.tar.Z 'patches.tar.gz')
-md5sums=('5d607a13dd42e559bfc90e278a8ec919'
- 'e65fffc8956e953f37a767ce9782b592')
+md5sums=('c4a3286f38a2faafc840017af4bd39d6'
+ '0d0285e6f81f24a961adf9d9f84973ce')
prepare() {
cd "$srcdir/hdfeos5"
# patches
- #patch -Np1 --ignore-whitespace -i ../patches/pthreads.patch
- patch -Np1 --ignore-whitespace -i ../patches/pkg-config.patch
- patch -Np1 --ignore-whitespace -i ../patches/configure.patch
- patch -Np1 --ignore-whitespace -i ../patches/gctp_remove.patch
- patch -Np1 --ignore-whitespace -i ../patches/libtool_fixes.patch
- patch -Np1 --ignore-whitespace -i ../patches/hdf5_transition.patch
- patch -Np1 --ignore-whitespace -i ../patches/hdf_hl.patch
- #patch -Np1 --ignore-whitespace -i ../patches/strcpy-overlap.patch
- patch -Np1 --ignore-whitespace -i ../patches/fix_HE5_EHHEisHE5.patch
- patch -Np1 --ignore-whitespace -i ../patches/hdf5_1.10.patch
+ #patch -Np1 --ignore-whitespace -i "$srcdir/patches/pthreads.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/pkg-config.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/configure.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/gctp_remove.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/libtool_fixes.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/hdf5_transition.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/hdf_hl.patch"
+ #patch -Np1 --ignore-whitespace -i "$srcdir/patches/strcpy-overlap.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/fix_HE5_EHHEisHE5.patch"
}
build() {
@@ -36,10 +35,10 @@ build() {
export CFLAGS="-D_HDFEOS5_THREADSAFE ${CFLAGS/O2/O0}"
export CXXFLAGS="${CFLAGS}"
- export CC="/usr/bin/h5cc"
+ export CC="/usr/bin/h5cc_18"
#export CPPFLAGS="-Df2cFortran -I/usr/include"
- ./configure CC=/usr/bin/h5cc --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
+ ./configure CC=/usr/bin/h5cc_18 --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
--disable-static \
--enable-static=no \
--enable-hl \