summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6c82799fc45..03343629efb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,27 @@
pkgname=hdf-eos5
pkgver=1.16
-pkgrel=1
+pkgrel=2
pkgdesc="The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library."
url="http://www.hdfeos.org/software/library.php"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('zlib' 'libaec' 'hdf5_18' 'gdal' 'hdf-eos-common')
+depends=('zlib' 'libaec' 'hdf5' 'gdal' 'hdf-eos-common')
options=('libtool' 'staticlibs')
-source=(ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.$pkgver.tar.Z)
-md5sums=('c4a3286f38a2faafc840017af4bd39d6')
+source=("ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.$pkgver.tar.Z"
+ "szip_cc.patch")
+md5sums=('c4a3286f38a2faafc840017af4bd39d6'
+ 'f4bf627e4dedaae3f142ca05253743eb')
build() {
cd "hdfeos5"
- #export LDFLAGS="-lhe5_hdfeos -lGctp -lhdf5_hl -lhdf5 -ljpeg -lz -lsz -lm"
- export LDFLAGS="-lhdf5_hl -lhdf5 -ljpeg -lz -lsz -lm"
-
- export CFLAGS="-D_HDFEOS5_THREADSAFE ${CFLAGS/O2/O0}"
- export CXXFLAGS="${CFLAGS}"
- export CC="/usr/bin/h5cc_18"
- #export CPPFLAGS="-Df2cFortran -I/usr/include"
- ./configure CC=/usr/bin/h5cc_18 --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
+ patch -p1 -i ../szip_cc.patch
+
+ ./configure CC=/usr/bin/h5cc --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
--disable-static \
--enable-static=no \
+ --with-szlib=/usr \
--enable-hl \
--enable-threadsafe \
--enable-linux-lfs \