summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d4c1a993e54..2b53381e72e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=hdf5-git
-pkgver=r38283.g66bcfd97a8
+pkgver=1.14.0.r95.gfc91e8856f
pkgrel=1
pkgdesc="General purpose library and file format for storing scientific data"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.hdfgroup.org/solutions/hdf5/"
license=('custom')
depends=('glibc' 'bash' 'libaec' 'zlib')
makedepends=('git' 'cmake') # gcc-fortran
-provides=('hdf5')
+provides=("hdf5=$pkgver")
conflicts=('hdf5')
options=('staticlibs')
source=("git+https://github.com/HDFGroup/hdf5.git")
@@ -19,9 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "hdf5"
- _rev=$(git rev-list --count --all)
+ _tag=$(git tag -l --sort -v:refname | grep -E 'hdf5-[0-9_]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "r%s.g%s" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^hdf5-//;s/_/./g'
}
build() {