summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 21 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4ace2f36174..99c4d26a2069 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,22 @@
pkgname=hdf5-java
_pkgname=hdf5
-pkgver=1.10.5
+pkgver=1.12.0
pkgrel=1
-pkgdesc="General purpose library and file format for storing scientific data, w/java bindings"
-arch=('x86_64')
+pkgdesc="General purpose library and file format for storing scientific data , w/java bindings"
+arch=(x86_64)
url="https://www.hdfgroup.org/hdf5"
-license=('custom')
-depends=('zlib' 'libaec' 'bash')
-makedepends=('cmake' 'time' 'gcc-fortran' 'java-environment')
-replaces=('hdf5-cpp-fortran')
-provides=('hdf5-cpp-fortran' 'hdf5-java' 'hdf5')
-conflicts=('hdf5' 'hdf5-openmpi')
-options=('staticlibs')
-source=("https://support.hdfgroup.org/ftp/HDF5/releases/${_pkgname}-${pkgver:0:4}/${_pkgname}-${pkgver/_/-}/src/${_pkgname}-${pkgver/_/-}.tar.bz2")
-sha256sums=('68d6ea8843d2a106ec6a7828564c1689c7a85714a35d8efafa2fee20ca366f44')
+license=(custom)
+depends=(zlib libaec bash)
+makedepends=(cmake time gcc-fortran jre-openjdk)
+replaces=(hdf5-cpp-fortran)
+provides=(hdf5-cpp-fortran hdf5)
+conflicts=(hdf5)
+options=(staticlibs)
+source=("https://support.hdfgroup.org/ftp/HDF5/releases/${_pkgname}-${pkgver:0:4}/${_pkgname}-${pkgver/_/-}/src/${_pkgname}-${pkgver/_/-}.tar.bz2"
+ hdf5-1.12.0-compat-1.6.patch)
+sha256sums=('97906268640a6e9ce0cde703d5a71c9ac3092eded729591279bf2e3ca9765f61'
+ '72ad497c56760bb3af8193c88d3fa264125829850b843697de55d934c56f7f44')
build() {
# Crazy workaround: run CMake to generate pkg-config file
@@ -29,23 +31,24 @@ build() {
-DHDF5_BUILD_HL_LIB=ON \
-DHDF5_BUILD_CPP_LIB=ON \
-DHDF5_BUILD_FORTRAN=ON \
- -DHDF5_BUILD_JAVA=ON \
+ -DHDF5_BUILD_JAVA=ON \
-DHDF5_ENABLE_Z_LIB_SUPPORT=ON \
-DHDF5_ENABLE_SZIP_SUPPORT=ON \
-DHDF5_ENABLE_SZIP_ENCODING=ON
# But don’t build with it, it’s quite broken
cd ../${_pkgname}-${pkgver/_/-}
./configure \
- JAVADOC='javadoc -Xdoclint:none' \
+ JAVADOC='javadoc -Xdoclint:none' \
--prefix=/usr \
--docdir=/usr/share/doc/hdf5/ \
+ --with-examplesdir='${DESTDIR}/${prefix}/share/doc/hdf5/examples' \
--enable-static \
--disable-sharedlib-rpath \
--enable-build-mode=production \
--enable-hl \
--enable-cxx \
--enable-fortran \
- --enable-java \
+ --enable-java \
--with-pic \
--with-zlib \
--with-szlib
@@ -66,16 +69,12 @@ check() {
package() {
cd ${_pkgname}-${pkgver/_/-}
-
make DESTDIR="${pkgdir}" install
-
- # Move examples to a proper place
- install -dm755 "${pkgdir}"/usr/share/doc/${_pkgname}
- mv "${pkgdir}"/usr/share/{hdf5_examples,doc/${_pkgname}/examples}
-
install -Dm644 COPYING -t "${pkgdir}"/usr/share/licenses/${_pkgname}
-
# Install pkg-config files from CMake tree
install -Dm644 ../build/CMakeFiles/hdf5{,_hl}{,_cpp}-${pkgver}.pc -t "${pkgdir}"/usr/lib/pkgconfig/
+ # Fix 1.6 compatibility for h5py
+ cd "${pkgdir}"/usr/include/
+ patch -p1 -i "${srcdir}"/hdf5-1.12.0-compat-1.6.patch
}