summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 32 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86f63cfb143f..83e2eb2930ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,34 +10,46 @@ url="http://www.hdfgroup.org/HDF5/"
license=('custom')
depends=('zlib' 'sh' 'gcc-libs')
makedepends=('time' 'gcc-fortran')
-conflicts=('hdf5')
-provides=('hdf5')
+provides=('hdf5_18')
+conflicts=('hdf5_18')
source=(ftp://ftp.hdfgroup.org/HDF5/current/src/${_pkgname}-${pkgver/_/-}.tar.bz2)
sha1sums=('640f1a46cb1b353339695355b4fca42df05be765')
build() {
- cd "$srcdir/${_pkgname}-${pkgver/_/-}"
- ./configure --prefix=/usr --disable-static \
- --enable-hl \
- --enable-cxx \
- --enable-fortran \
- --enable-fortran2003 \
- --enable-linux-lfs \
- --enable-build-mode=production \
- --with-pic \
- --docdir=/usr/share/doc/hdf5/ \
- --with-pthread=/usr/lib/ \
- --disable-sharedlib-rpath
- make
+ cd "$srcdir/${_pkgname}-${pkgver/_/-}"
+ ./configure --prefix=/usr --disable-static \
+ --enable-hl \
+ --enable-cxx \
+ --enable-fortran \
+ --enable-fortran2003 \
+ --enable-linux-lfs \
+ --enable-build-mode=production \
+ --with-pic \
+ --docdir=/usr/share/doc/hdf5_18/ \
+ --with-pthread=/usr/lib \
+ --disable-sharedlib-rpath \
+ --libdir=/usr/lib/hdf5_18 \
+ --includedir=/usr/include/hdf5_18
+ make
}
package() {
- cd "$srcdir/${_pkgname}-${pkgver/_/-}"
+ cd "$srcdir/${_pkgname}-${pkgver/_/-}"
- make -j1 DESTDIR="${pkgdir}" install
+ make -j1 DESTDIR="${pkgdir}" install
- install -d -m755 "$pkgdir/usr/share/licenses/${pkgname}"
- install -m644 "$srcdir/${_pkgname}-${pkgver/_/-}/COPYING" \
- "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ rm -rf "${pkgdir}"/usr/share/hdf5_examples
+
+ for file in "${pkgdir}"/usr/bin/*
+ do
+ mv "${file}" "${file}"_18
+ done
+
+ install -d m755 "${pkgdir}"/etc/ld.so.conf.d
+ echo /usr/lib/hdf5_18 >> "${pkgdir}"/etc/ld.so.conf.d/hdf5_18.conf
+
+ install -d -m755 "$pkgdir/usr/share/licenses/${pkgname}"
+ install -m644 "$srcdir/${_pkgname}-${pkgver/_/-}/COPYING" \
+ "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}