summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 6 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83e2eb2930ab..2094f9e7bc02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=hdf5_18-cpp-fortran
_pkgname=hdf5
pkgver=1.8.17
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc="General purpose library and file format for storing scientific data"
url="http://www.hdfgroup.org/HDF5/"
license=('custom')
depends=('zlib' 'sh' 'gcc-libs')
makedepends=('time' 'gcc-fortran')
-provides=('hdf5_18')
-conflicts=('hdf5_18')
+conflicts=('hdf5')
+provides=('hdf5')
source=(ftp://ftp.hdfgroup.org/HDF5/current/src/${_pkgname}-${pkgver/_/-}.tar.bz2)
sha1sums=('640f1a46cb1b353339695355b4fca42df05be765')
@@ -25,11 +25,9 @@ build() {
--enable-linux-lfs \
--enable-build-mode=production \
--with-pic \
- --docdir=/usr/share/doc/hdf5_18/ \
- --with-pthread=/usr/lib \
- --disable-sharedlib-rpath \
- --libdir=/usr/lib/hdf5_18 \
- --includedir=/usr/include/hdf5_18
+ --docdir=/usr/share/doc/hdf5/ \
+ --with-pthread=/usr/lib/ \
+ --disable-sharedlib-rpath
make
}
@@ -38,16 +36,6 @@ package() {
make -j1 DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}"/usr/share/hdf5_examples
-
- for file in "${pkgdir}"/usr/bin/*
- do
- mv "${file}" "${file}"_18
- done
-
- install -d m755 "${pkgdir}"/etc/ld.so.conf.d
- echo /usr/lib/hdf5_18 >> "${pkgdir}"/etc/ld.so.conf.d/hdf5_18.conf
-
install -d -m755 "$pkgdir/usr/share/licenses/${pkgname}"
install -m644 "$srcdir/${_pkgname}-${pkgver/_/-}/COPYING" \
"$pkgdir/usr/share/licenses/${pkgname}/LICENSE"