summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 6 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45a503d8120a..d85f4a02b1d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,18 @@ pkgname=hdrview-git
provides=('hdrview')
_pkgname=hdrview
pkgver=269.8436cf9
-pkgrel=2
+pkgrel=3
pkgdesc='HDRView is a simple research-oriented high-dynamic range image viewer with an emphasis on examining and comparing images, and including minimalistic tonemapping capabilities'
url='https://bitbucket.org/wkjarosz/hdrview'
arch=('x86_64')
license=('BSD')
makedepends=('cmake' 'git')
+depends=('zlib')
sha256sums=('SKIP'
- '29450b60ca46062663ec603a0b68f8500cf882761654f756b81afb368845fdc5'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+ '29450b60ca46062663ec603a0b68f8500cf882761654f756b81afb368845fdc5')
source=('git+https://bitbucket.org/wkjarosz/hdrview.git'
- 'hdrview-git.patch'
- 'git+https://github.com/cxong/tinydir.git'
- 'git+https://github.com/docopt/docopt.cpp.git'
- 'git+https://github.com/gabime/spdlog.git'
- 'git+https://github.com/syoyo/tinydngloader.git'
- 'git+https://github.com/mitsuba-renderer/openexr.git'
- 'git+https://github.com/mitsuba-renderer/zlib.git'
- 'git+https://github.com/wjakob/nanogui.git')
+ 'hdrview-git.patch')
pkgver() {
cd ${_pkgname}
@@ -41,17 +28,8 @@ prepare() {
# Apply patch to make sure missing icons paths aren't used
patch --forward --strip=1 --input=${srcdir}/hdrview-git.patch
- # Set up submodules as per the wiki's guidelines here:
- # https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git_Submodules
- git submodule init
- git config --local submodule.ext/tinydir.url ${srcdir}/tinydir
- git config --local submodule.ext/docopt.url ${srcdir}/docopt.cpp
- git config --local submodule.ext/spdlog.url ${srcdir}/spdlog
- git config --local submodule.ext/openexr.url ${srcdir}/openexr
- git config --local submodule.ext/zlib.url ${srcdir}/zlib
- git config --local submodule.ext/nanogui.url ${srcdir}/nanogui
-
- # Initialize submodules' recursive submodules
+ # The preferred method of working with submodules in the AUR guidelines
+ # doesn't seem to work recursively, so we use the "naive" method instead
git submodule update --init --recursive
}