summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2bd0a95826c..ace03be2b229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,8 @@ pkgver() {
git -C $pkgname describe --tags --abbrev=10 | sed 's/^v//; s/-/+/; s/-/./'
}
-build() {
+prepare() {
+ # Run cmake in `prepare()` since it will download stuff.
cmake -S $pkgname -B build \
-G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -31,6 +32,9 @@ build() {
-DOPENEXR_INSTALL=OFF \
-DOPENEXR_INSTALL_PKG_CONFIG=OFF \
-DOPENEXR_INSTALL_TOOLS=OFF
+}
+
+build() {
cmake --build build
}