summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b99bb6a31f73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='headset-charge-indicator'
+pkgname="${_pkgname}-git"
+pkgver=1.0.0.0.r33.g795705a
+pkgrel=1
+pkgdesc='Simple app-indicator for GNOME desktops to display the battery charge of some wireless headsets'
+arch=('any')
+url='https://github.com/centic9/headset-charge-indicator'
+license=('BSD')
+depends=('gnome-icon-theme' 'headsetcontrol' 'libappindicator-gtk3' 'python')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dvm755 "${_pkgname}.py" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: